Back to overview
Degraded
Internal misconfiguration caused SSL certificated to be invalid
Jun 27 at 04:00pm CEST
Affected services
Landing Page
Resolved
Jun 28 at 10:35am CEST
An internal misconfiguration on our server caused the SSL certificates to be invalid. This only affected pages that were not on the domain "mail.astolfo.email". E-Mail services continued functioning as normal.
Affected services
Landing Page
Created
Jun 27 at 04:00pm CEST
There are issues with the SSL certificates. Services on the domain "mail.astolfo.email" are not affected and continue to be operational.
Affected services
Landing Page